Список ошибок работы с HASP ключом
Перейти к навигации
Перейти к поиску
HASP_STATUS_OK = 0; { Request successfully completed }
HASP_MEM_RANGE = 1; { Request exceeds memory range of a HASP file }
HASP_INV_PROGNUM_OPT = 2; { Legacy HASP HL Run-time API: Unknown/Invalid Feature ID option }
HASP_INSUF_MEM = 3; { System is out of memory }
HASP_TMOF = 4; { Too many open Features/login sessions }
HASP_ACCESS_DENIED = 5; { Access to Feature, HASP protection key or functionality denied }
HASP_INCOMPAT_FEATURE = 6; { Legacy decryption function cannot work on Feature }
HASP_CONTAINER_NOT_FOUND = 7; { DEPRECATED }
HASP_HASP_NOT_FOUND = 7; { Sentinel HASP protection key not available }
HASP_TOO_SHORT = 8; { Encrypted/decrypted data length too short to execute function call }
HASP_INV_HND = 9; { Invalid login handle passed to function }
HASP_INV_FILEID = 10; { Specified File ID not recognized by API }
HASP_OLD_DRIVER = 11; { Installed driver or daemon too old to execute function }
HASP_NO_TIME = 12; { Real-time clock (rtc) not available }
HASP_SYS_ERR = 13; { Generic error from host system call }
HASP_NO_DRIVER = 14; { Required driver not installed }
HASP_INV_FORMAT = 15; { Unrecognized file format for update }
HASP_REQ_NOT_SUPP = 16; { Unable to execute function in this context }
HASP_INV_UPDATE_OBJ = 17; { Binary data passed to function does not contain valid update }
HASP_KEYID_NOT_FOUND = 18; { HASP protection key not found }
HASP_INV_UPDATE_DATA = 19; { Required XML tags not found; Contents in binary data are missing }
HASP_INV_UPDATE_NOTSUPP = 20; { Update request not supported by Sentinel HASP protection key }
HASP_INV_UPDATE_CNTR = 21; { Update counter set incorrectly }
HASP_INV_VCODE = 22; { Invalid Vendor Code passed }
HASP_ENC_NOT_SUPP = 23; { Sentinel HASP protection key does not support encryption type }
HASP_INV_TIME = 24; { Passed time value outside supported value range }
HASP_NO_BATTERY_POWER = 25; { Real-time clock battery out of power }
HASP_NO_ACK_SPACE = 26; { Acknowledge data requested by update, but ack_data parameter is null }
HASP_TS_DETECTED = 27; { Program running on a terminal server }
HASP_FEATURE_TYPE_NOT_IMPL = 28; { Requested Feature type not implemented }
HASP_UNKNOWN_ALG = 29; { Unknown algorithm used in H2R/V2C file }
HASP_INV_SIG = 30; { Signature verification operation failed }
HASP_FEATURE_NOT_FOUND = 31; { Requested Feature not available }
HASP_NO_LOG = 32; { Access log not enabled }
HASP_LOCAL_COMM_ERR = 33; { Communication error between API and local HASP License Manager }
HASP_UNKNOWN_VCODE = 34; { Vendor Code not recognized by API }
HASP_INV_SPEC = 35; { Invalid XML specification }
HASP_INV_SCOPE = 36; { Invalid XML scope }
HASP_TOO_MANY_KEYS = 37; { Too many Sentinel HASP protection keys currently connected }
HASP_TOO_MANY_USERS = 38; { Too many concurrent user sessions currently connected }
HASP_BROKEN_SESSION = 39; { Session been interrupted }
HASP_REMOTE_COMM_ERR = 40; { Communication error between local and remote HASP License Managers }
HASP_FEATURE_EXPIRED = 41; { Feature expired }
HASP_OLD_LM = 42; { HASP License Manager version too old }
HASP_DEVICE_ERR = 43; { Input/Output error occurred }
HASP_UPDATE_BLOCKED = 44; { Update installation not permitted; This update was already applied }
HASP_TIME_ERR = 45; { System time has been tampered with }
HASP_SCHAN_ERR = 46; { Communication error occurred in secure channel }
HASP_STORAGE_CORRUPT = 47; { Corrupt data exists in secure storage area of HASP SL protection key }
HASP_NO_VLIB = 48; { Unable to find Vendor library }
HASP_INV_VLIB = 49; { Unable to load Vendor library }
HASP_SCOPE_RESULTS_EMPTY = 50; { Unable to locate any Feature matching scope }
HASP_VM_DETECTED = 51; { Program running on a virtual machine }
HASP_HARDWARE_MODIFIED = 52; { HASP SL key incompatible }
HASP_USER_DENIED = 53; { Login denied because of user restrictions }
HASP_UPDATE_TOO_OLD = 54; { out of sequence }
HASP_UPDATE_TOO_NEW = 55; { Update to old }
HASP_OLD_VLIB = 56; { Old vlib }
HASP_UPLOAD_ERROR = 57; { Upload via ACC failed, e.g. because of illegal format }
HASP_INV_RECIPIENT = 58; { Invalid XML "recipient" parameter }
HASP_INV_DETACH_ACTION = 59; { Invalid XML "action" parameter }
HASP_TOO_MANY_PRODUCTS = 60; { scope does not specify a unique product }
HASP_INV_PRODUCT = 61; { Invalid Product information }
HASP_UNKNOWN_RECIPIENT = 62; { Unknown Recipient }
HASP_INV_DURATION = 63; { Invalid Duration }
HASP_CLONE_DETECTED = 64; { Cloned HASP SL secure storage detected }
HASP_UPDATE_ALREADY_ADDED = 65; { Specified v2c update already installed in the LLM }
HASP_HASP_INACTIVE = 66; { Specified Hasp Id is in Inactive state }
HASP_NO_DETACHABLE_FEATURE = 67; { No detachable feature exists }
HASP_NO_DEATCHABLE_FEATURE = 67; { No detachable feature exists (typo kept for compatibility) }
HASP_TOO_MANY_HOSTS = 68; { scope does not specify a unique Host }
HASP_REHOST_NOT_ALLOWED = 69; { Rehost is not allowed for any license }
HASP_LICENSE_REHOSTED = 70; { License is rehosted to other machine }
HASP_REHOST_ALREADY_APPLIED = 71; { Old rehost license try to apply }
HASP_CANNOT_READ_FILE = 72; { File not found or access denied }
HASP_EXTENSION_NOT_ALLOWED = 73; { Extension of license not allowed as number of detached licenses is greater than current concurrency count }
HASP_DETACH_DISABLED = 74; { Detach of license not allowed as product contains VM disabled feature and host machine is a virtual machine }
HASP_REHOST_DISABLED = 75; { Rehost of license not allowed as container contains VM disabled feature and host machine is a virtual machine }
HASP_DETACHED_LICENSE_FOUND = 76; { Format SL-AdminMode or migrate SL-Legacy to SL-AdminMode not allowed as container has detached license }
HASP_RECIPIENT_OLD_LM = 77; { Recipient of the requested operation is older than expected}
HASP_SECURE_STORE_ID_MISMATCH=78; { Secure storage ID mismatch }
HASP_NO_API_DYLIB = 400; { API dispatcher: API for this Vendor Code was not found }
HASP_INV_API_DYLIB = 401; { API dispatcher: Unable to load API; DLL possibly corrupt? }
HASP_INVALID_OBJECT = 500; { C++ API: Object incorrectly initialized }
HASP_INVALID_PARAMETER = 501; { C++ API: Invalid function parameter }
HASP_ALREADY_LOGGED_IN = 502; { C++ API: Logging in twice to the same object }
HASP_ALREADY_LOGGED_OUT = 503; { C++ API: Logging out twice of the same object }
HASP_OPERATION_FAILED = 525; { .NET API: Incorrect use of system or platform }
HASP_NO_EXTBLOCK = 600; { Internal use: no classic memory extension block available }
HASP_INV_PORT_TYPE = 650; { Internal use: invalid port type }
HASP_INV_PORT = 651; { Internal use: invalid port value }
HASP_NOT_IMPL = 698; { Requested function not implemented }
HASP_INT_ERR = 699; { Internal error occurred in API }
HASP_FIRST_HELPER = 2001; { Reserved for HASP helper libraries }
HASP_FIRST_HASP_ACT = 3001; { Reserved for HASP Activation API }
HASP_NEXT_FREE_VALUES = 7001; { }